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 Iniziare ad imparare Geomedia Professional!

Questo corso introduttivo vi guiderà attraverso le caratteristiche basilari di GeoMedia® Professsional, in primo luogo 
utilizzando i dati di esempio forniti con l'applicazione (che riguardano gli Stati Uniti), ed in seguito creando una mappa 
delle stazioni sciistiche facendo uso delle funzioni di digitalizzazione del prodotto.

Questa guida è stata pensata per essere utilizzata dall'inizio alla fine, seguendo le sezioni in ordine, dato che gli esempi di 
una sezione si basano sui risultati della sezione seguente.  D'altro canto le sezioni 1-9 utilizzano un insieme di dati diverso 
da quello delle sezioni 10-15, per cui è possibile iniziare il corso direttamente dalla sezione 10, se ad esempio si è 
interessati solo alle funzioni di cattura dei dati.  Nella sezione 15, è possibile scegliere l'utilizzo dei dati della sezione 14 o 
della sezione 9.  Bisogna ricordare che questa guida presenta un particolare flusso di lavorazione, in realtà è possibile 
utilizzare molti altri flussi.

IMPORTANTE: Se uno dei file USSampleData.mdb, SkiResort.mdb o SkiResort.gws dovesse essere stato modificato (ad 
esempio, da un altro utente), alcuni esempi potrebbero non riuscire.  Si raccomanda di iniziare questo corso con una copia 
intatta di questi file, che si può ottenere lanciando il setup di Geomedia Professional, selezionando l'opzione Custom 
Setup, e quindi selezionando Sample Data.   

ATTENZIONE: Lanciando il setup di Geomedia Professional, i file USSampleData.mdb, SkiResort.mdb, e SkiResort.
gws saranno soprascritti con lo stesso nome.  Prima quindi di fare questa operazione, fate una copia di sicurezza di questi 
file se volete mettere in salvo eventuali modifiche apportate.

Se possibile, tenete questo corso a lato della finestra di Geomedia Professional.  La finestra del tutorial dovrà essere larga 
abbastanza da poter leggere le istruzioni, ma non tanto da coprire la finestra di Geomedia, in modo da poter selezionare i 
comandi indicati e visaulizzare i risultati.
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1- Benvenuti in GeoMedia Professional

Note: 

●     è consigliabile (ma non obbligatorio) utilizzare questo corso ad una risoluzione di 1024x768.  Se avete un'altra 
risoluzione, i risultati grafici potrebbero essere leggermente diversi da quelli mostrati in questa guida.

●     Mentre seguirete il corso, leggerete le istruzioni scorrendo le pagine della guida e eseguendo le operazioni (es. 
selezionando un comando) nella finestra di Geomedia Professional.  Se in un dato istante Geomedia sembra non 
rispondere ai comandi (es. premendo ESC non si esce da un comando), assicurarsi che la finestra di Geomedia 
(e non quella della guida), sia la finestra correntemente attiva.

SUGGERIMENTI ANIMATI: Se il vostro programma di navigazione è Internet Explorer® version 4.0 o superiore, 
potrete vedere delle brevi animazioni esplicative.  Queste animazioni comunque mostrano caratteristiche extra di 
Geomedia Professional, non fanno propriamente parte del flusso di lavoro.

NOTA SULLA TRADUZIONE IN ITALIANO: i termini inglesi che sono entrati nell'uso comune non sono stati 
tradotti nel testo di questo corso (come ad esempio feature o Workspace), quando il loro significato non è chiarito dal 
contesto, il termine è seguito dalla sua traduzione riportata fra parentesi e preceduta dal segno di uguaglianza, come 
esemplifica il prossimo titolo. 

Create un GeoWorkspace (=Spazio di Lavoro Geografico)

Per prima cosa creeremo un nuovo GeoWorkspace.  Il GeoWorkspace è l'area in cui si lavora e attraverso la quale si 
visualizzano i dati geografici.  Se poi si è connessi ad un magazzino dati in lettura scrittura (come vedremo nelle prossime 
sezioni) il GeoWorkspace permetterà inoltre di manipolare i dati geografici. 

1.  Lanciare GeoMedia Professional (se non lo si è già fatto!).

2.  Se appare sullo schermo il dialogo Welcome to GeoMedia Professional (=Benvenuti in Geomedia 
Professional) cliccate sul bottone Create new GeoWorkspace (=Crea un nuovo Spazio di Lavoro).

-OPPURE-

Se appare sullo schermo il dialogo GeoMedia Professional, selezionate l'opzione GeoWorkspace template
(=Schema di Spazio di Lavoro), e cliccate su OK.

-OPPURE-

Selezionate il menù File > New GeoWorkspace. 

3.  Nel dialogo New, accettate lo schema di default, selezionando il file normal.gwt, e assicurandosi che l'opzione 
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1- Benvenuti in GeoMedia Professional

Document sia selezionata, quindi premete il bottone New.  

Il GeoWorkspace sarà creato, il suo nome sarà quello di default: GeoWorkspace1.  

Il GeoWorkspace contiene una legenda vuota e una finestra della mappa. La finestra della mappa, il cui titolo è 
MapWindow1, è la finestra in cui visualizzeremo i dati geografici geometrici e le immagini.

Salvare il GeoWorkspace

Prima di continuare, salviamo il GeoWorkspace.  

1.  Selezionare il menù File > Save GeoWorkspace(=Salva lo spazio di lavoro).  

2.  Nel campo File name, cancellate il testo corrente, e digitate il nome learning.  

3.  Cliccate su Save.

Il file sarà salvato nella cartella \GeoWorkspaces col nome di learning.gws.

NOTA: Ogni volta che interromperete gli esempi di questa guida, salvate il GeoWorkspace prima di uscire da 
Geomedia. 

Continua nella prossima sezione 2-Utilizzo delle Warehouse per connettere i dati

Copyright © 1996-2001 Intergraph Corporation. Tutti i diritti riservati.

Traduzione di Claudio Rocchini, Istituto Geografico Militare 

Including software, file formats, and audiovisual displays; may be used pursuant to applicable 
software license agreement; contains confidential and proprietary information of Intergraph and/or 
third parties which is protected by copyright and trade secret law and may not be provided or 
otherwise made available without proper authorization.

Intergraph, GeoMedia, and RIS are registered trademarks of Intergraph Corporation. SmartSketch is 
a trademark of Intergraph Corporation. Windows and Windows NT are registered trademarks of 
Microsoft Corporation. NT is a registered trademark of Northern Telecom Limited. MapInfo is a 
registered trademark of MapInfo Corporation. All other brands and product names are trademarks of 
their respective owners. 

Although this copyright protects the content of Learning GeoMedia Professional as the Intellectual 
Property of Intergraph, Intergraph grants you, the user, permission to print any topic in this tutorial 
for your personal use while operating the software.
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2- Utilizzo delle Warehouse per connettere i dati

 Utilizzo delle Warehouse per connettere i dati

In questa sezione, ci si connetterà ad una warehouse esistente, in modo da interrogarne i dati.  Inoltre creeremo una nuova 
warehouse in cui sarà possibile scrivere nuovi dati.  Geomedia utilizza le warehouse come sorgenti di dati..  Ogni 
warehouse contiene un solo tipo di dato geografico, come ad esempio Access, MGE, FRAMME, MGE Segment Manager, 
ARC/INFO, Oracle, ArcView, MapInfo, MGDM, oppure CAD.   

Connessione ad una Warehouse Access esistente

GeoMedia Professional permette di connettersi e di visualizzare più tipi diversi di warehouse contemporaneamente.  Ad 
esempio, è possibile connettersi ad una warehouse MGE, ad una di tipo FRAMME e ad una ARC/INFO e visualizzare 
tutti i dati in una mappa unica.

In GeoMedia Professional, una feature(=caratteristica) è un'entità geografica rappresentata su di una mappa e definita da 
una serie di attributi non grafici, memorizzati in una base di dati.  Una serie di feature class (=classe di caratteristiche) è 
una classificazione in classi di oggetti, ogni istanza di una feature appartiene ad una di queste classi.  I dati di esempio di 
questo progetto contengono classi di features tipo:States, Cities, e Interstates.  Ad esempio, Minnesota è una feature che 
appartiene alla classe di feature States, mentre Boston è una feature appartenente alla classe Cities.

Per prima cosa bisogna connettersi ad una warehouse, ad esempio USSampleData.mdb, in modo da poter visualizzarne i 
dati. 

1.  Selezionare Warehouse > New Connection (=nuova connessione).

Il Warehouse Connection Wizard (=Mago delle connessioni) Mostra i vari tipi di wareouse con cui è 
possibile connettersi. 

2.  Selezionare Access, and cliccare su Next.  

3.  Nel campo Connection name(=Nome della connessione), cancellare il testo contenuto e digitare 
Connection to US Data.

4.  Per selezionare un file di database, fare click su Browse(=Mostra).  

5.  Selezionare il file USSampleData.mdb, e cliccare su Open(=Apri).   

6.  Cliccare su Next.

7.  Mantenendo selezionata l'opzione Access all features in the warehouse(=Accedi a tutte le feature della 
warehouse), cliccare su Next.

8.  Selezionare l'opzione Let the wizard open the connection as read-only (=Di' al mago di connettersi in sola 
lettura). 

Dato che state per connettervi in sola lettura, non c'è pericolo di distruggere accidentalmente i dati contenuti nel 
file USSampleData.mdb.

9.  Cliccare su Finish(=Fine).

Aggiunta di classi di Feature

Adesso, dalla warehouse in sola lettura, aggiungeremo due classi di feature alla finestra di visualizzazione. 

1.  Selezionare Legend > Add Feature Class(=Legenda, aggiungi classe di feature).
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2- Utilizzo delle Warehouse per connettere i dati

2.  Nel dialogo Add Feature Class Entry, assicurarsi che sia selezionata la connessione denominata Connection 
to US Data.

3.  Tenendo premuto il tasto CTRL, selezionare le voci StateNameLabels e States dalla lista delle classi di feature.

4.  Cliccare su OK.

Due punti vengono aggiunti alla legenda (States e labels), e le feature sono visualizzate nella finestra della 
mappa.  

5.  Massimizzare la finestra della mappa cliccando sull'icona in alto a sinistra della finestra e selezionando il menù 
Maximize.

6.  Selezionare il menù View > Fit All(=Adatta tutto) per adattare il contenuto alla finestra. 

Uno sguardo al sistema di riferimento del GeoWorkspace

GeoMedia Professional seleziona un sistema di riferimento di default per la visualizzazione, che in seguito è possibile 
cambiare per adattarlo al sistema di riferimento dei propri dati.  Geomedia inoltre ha la possibilità di far combaciare 
automaticamente il sistema di riferimento della visualizzazione con quello delle warehouse connesse. 

1.  Selezioanre Tools > Options(=Strumenti, Opzioni).

2.  Nella pagina General, notare l'opzione Match GeoWorkspace and Warehouse coordinate systems—When 
making first connection(=Fai combaciare il sistema di riferimento del Worskspace e della Warehouse - alla 
prima connessione) e When creating a new warehouse (=alla creazione di una nuova Warehouse).

Queste opzioni permettono di risparmiare tempo, copiando il sistema di riferimento di visualizzazione dati 
connessi (come faremo in seguito).  

3.  Con entrambe queste opzioni selezionate, cliccare su OK nel dialogo Options.

Dati che abbiamo aperto la connessione al file USSampleData in sola lettura, non è possibile cambiare il suo 
sistema di riferimento.  Invece è possibile cambiare il sistema di riferimento del GeoWorkspace, utilizzato nella 
visualizzazione.  In questo flusso di lavoro comunque, non cambieremo mai il sistema di riferimento, anche se è 
possibile visualizzarne i parametri.

4.  Selezionare il menù View > GeoWorkspace Coordinate System(=Visualizza, Sistema di riferimento del 
GeoWorkspace).

5.  Nella pagina Storage Space(=Spazio di memorizzazione) del dialogo Warehouse Coordinate System, 
osservare che l'opzione Projection(=Proiezione) è selezionata nel riquadro Base storage type.

6.  Selezionare la pagina Projection Space(=Spazio di proiezione).

7.  Osservare che nella lista degli Projection algorithm(=Metodi di proiezione) è selezionata l'opzione Albers 
Equal Area.

8.  Cliccare su Projection Parameters(=Parametri di proiezione).

Osservare i parametri usati nella proiezione di Albers, che è una proiezione conica.  Ogni tipo di proiezione 
cilindrica, azimutale e conica ha i propri parametri di proiezione, a seconda delle proprietà geometriche del tipo 
di proiezione.

9.  Cliccare su Cancel nel dialogo Projection Parameters.

Le proprietà di visualizzazione
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2- Utilizzo delle Warehouse per connettere i dati

Setteremo adesso la scala nominale della mappa e la scala di visualizzazione della finestra di visualizzazione.  Fintanto 
che non avremo familiarità con il funzionamento dei vari settaggi, possiamo pensare alla scala nominale come il fattore di 
scala usato nella stampa su carta.  Questo fattore di scala approssima la scala con cui sono stati creati i dati (che può 
essere nota oppure no).  La definizione dello stile (spessore delle linee, tipo di carattere e dimensione dei simboli) può 
essere collegata alla scala nominale.  La scala di visualizzazione (Display Scale) è la scala con cui sono correntemente 
visualizzati gli oggetti nella finestra della mappa.  Ad esempio, se zummate in avanti od indietro la mappa, la scala di 
visualizzazione aumenta o diminuisce.

La definizione dello stile (spessore delle linee, tipo di carattere, dimensione dei simboli) si comporta in modo diverso a 
seconda che si sia impostata la modalità Size remains constant as display scale changes(=La dimensione rimane 
costante al variare della scala) o la modalità opposta Size changes as display scale changes (true at nominal map scale)
(=La dimensione cambia al variare della scala). . La dimensione del testo, ad esempio, se settata a Size remains constant 
as display scale changes, non varia se cambiamo la scala di visualizzazione (zummando avanti o indietro); cambia solo 
se viene modificata la scala nominale della mappa.  Se invece il testo e settato a Size changes as display scale changes 
(true at nominal map scale), viene visualizzato alla dimensione settata solo alla scala nominale, mentre cambia 
dimensione quando la scala di visualizzazione viene cambiata.  Il testo quindi appare più grande quando si zumma in 
avanti, o rimpicciolisce quando si zumma indietro.

Nota: ci sono due posti da cui è possibile cambiare i settaggi dello stile.  Il dialogo Display Properties, che abbiamo 
usato in questa esercitazione, permette di selezionare un particolare stile per tutti i punti della legenda. Il dialogo Style 
Definition permette invece di scegliere uno stile diverso per ogni singolo punto della legenda.

In questo esercizio, setteremo la scala nominale della mappa, e la scala di visualizzazione iniziale.  Setteremo inoltre tutti 
gli oggetti con l'opzione Size changes as display scale changes (true at nominal map scale), in modo che le dimensioni 
cambino al variare della scala di visualizzazione: gli oggetti della mappa (State-Name-Labels e State-Border) appariranno 
più spessi o più fini al variare del fattore di zoom.

1.  Selezionare View > Display Properties.

Appare il dialogo Display Properties.

2.  Nella lista Display scale, selezionare 25,000,000 (25 milioni).

3.  Nel campo Nominal map scale, digitare 20,000,000 (20 milioni).

4.  Ceccare il flag Size changes as display scale changes (true at nominal map scale).

Tutti i gli stile della legenda saranno aggiornati da questi valori.

5.  Cliccare su Apply(=Applica).

6.  Cliccare quindi su Close.

Nota: Non bisogna preoccuparsi se la mappa non si adatta completamente alla finestra.  Questo è dovuto alle 
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2- Utilizzo delle Warehouse per connettere i dati

dimensioni correnti della finestra della mappa

7.  Osservare l'angolo in basso a destra della barra di stato, in fondo alla finestra.  è possibile vedere la scala di 
visualizzazione corrente (1:25,000,000).  Se questa non appare, selezionare Tools > Options.  nella pagina 
General , assicurarsi che le opzioni Display status barDisplay zoom scale siano selezionate.   Cliccare su OK 
nel dialogo Options.  Se ancora non è possibile visualizzare la scala corrente, è possibile che non ci sia spazio 
sufficiente nella finestra di Geomedia.  In questo caso è necessario allargare la finestra orizzontalmente in modo 
da visualizzare l'intera barra di stato.

Creazione di una Warehouse Access

Creeremo adesso una Warehouse Access.  Le warehouse Access e Oracle sono gli unici tipi di warehouse che è possibile 
creare e modificare con GeoMedia Professional, mentre è possibile connettersi con gli altri tipi di warehouse solo in 
lettura.  Gli altri tipi di warehouse possono essere creati con i loro relativi prodotti software specifici (MGE, FRAMME, 
ARC/INFO). 

1.  Selezionare Warehouse > New Warehouse(=Nuova warehouse).  

2.  Selezionare lo schema di default normal.mdt, assicurandosi che il nome normal.mdt appaia nel campo File 
name, e cliccare su New. 

3.  Nel campo File name, digitare il nome learning come nome della warehouse da creare.  

4.  Assicurarsi che il campo Save as type sia settato a Access, e cliccare su Save.

Il file sarà salvato nella cartella \Warehouses col nome learning.mdb.

Adesso la nuova warehouse è vuota..  Nella prossima sezione caricheremo dei dati dentro la nuova warehouse, 
pescandoli dalle altra connessione (Connection to US Data).  

5.  Per verificare che il sistema di riferimento della nuova warehouse è lo stesso del GeoWorkspace, selezionare il 
menù Warehouse > Warehouse Coordinate System(=Sistema di riferimento della Warehouse).

6.  Selezionare learning dalla lista delle connessioni disponibili, e cliccare su OK.

7.  Cliccare sulla pagina Projection Space.

Nel campo Projection algorithm è selezionato il valore Albers Equal Area, che è la stesso del GeoWorkspace.

8.  Cliccare su Cancel.

Cambiare lo stile delle Labels (=etichette)

Adesso modificheremo lo stile dei nomi degli stati, in modo da renderle più piccole e più spesse. 

1.  Selezionare il menù Legend > Properties (=Proprietà).

2.  Selezionare la riga StateNameLabels (se non già evidenziata) cliccando sul selettore della riga, che è il primo 
elemento della riga stessa.

3.  Cliccare sul bottone Style nell'angolo in basso a destra del dialogo.

4.  Selezionare un size di 8 points (=punti) dalla lista a discesa Size, e ceccare l'opzione Bold (=Grassetto).

Notare l'opzione Size remains constant as display scale changes (=La dimensione rimane costante al variare 
della scala), nell'angolo in basso a sinistra del dialogo.  Da qui potete modificare questa opzione per ogni 
oggetto della legenda individualmente.  In questo momento l'opzione non è selezionata, dato che avete applicato 
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2- Utilizzo delle Warehouse per connettere i dati

l'opzione inversa ad ogni elemento della legenda, utilizzando il dialogo Display properties (=Propietà dello 
schermo) nell'esercizio precedente.

5.  Cliccare su OK per chiudere il dialogo.

6.  Salvare il GeoWorkspace.

Inserire un'immagine

Esercizio facoltativo.  è possibile inserire un'immagine raster fornita come esempio nella cartella Warehouses .  

Nota: Questa immagine, USSampleImage.tif, fornita con l'istallazione tipica, è grande circa 24 mega.  Se si è scelto di non 
installare questo dato oppure non interessano le immagini raster, si può saltare questa esercitazione e proseguire 
direttamente con la prossima sezione. 

1.  Selezionare il menù Insert > Image (=Inserisci Immagine).

2.  Cliccare su Browse (=Mostra).

3.  Nel campo Files of Type (=Documenti di tipo...), selezionare TIFF (*.tif).

4.  Aprire il file USSampleImage.tif nella cartella Warehouses.

L'opzione Placement mode(=Modalità di piazzamento) è settata su Georeferenced (=Georiferita).

5.  Cliccare su OK nel dialogo Insert Image.

L'immagine verrà inserita.

6.  Selezionare il menù Legend > Properties (=Propietà legenda).

è possibile modificare lo stile dell'immagine.

7.  Per modificare lo stile di un'immagine, è possibile selezionare il punto della legenda relativo all'immagine e 
quindi cliccare sul bottone Style, oppure più semplicemente è possibile fare doppio click sulla cella dello stile, 
nella riga della legenda che contiene il punto USSampleImage.tif.

Verrà visualizzato il dialogo Image Display (=Visualizzazione immagine).

8.  Nella pagina Greyscale/Color Image(=Immagine colore/scale di grigio), digitare 75 nel campo Brightness 
(=luminosità).
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2- Utilizzo delle Warehouse per connettere i dati

9.  Cliccare su OK nel dialogo Image Display.

10.  Mantenendo selezionata la riga con USSampleImage.tif, cliccate sulla freccia per abbassare la priorità, in 
questo modo l'immagine verrà posizionata in fondo della legenda..

11.  Cliccare su OK nel dialogo Legend Properties.

Il punto della legenda USSampleImage.tif sarà spostato in ultima posizione.

12.  Visualizzare il dialogo Style Definition (=Definizione dello Stile) utilizzando un'altra scorciatoia: fare doppio 
click sull'icona dello stile nella finestra della legenda, sulla riga corrispondente a States.

13.  Nella pagina Area Boundary(=Bordo delle Aree), cliccare sul bottone Color.

14.  Nel dialogo Color che verrà mostrato, selezionare il quadratino grigio scuro nella tavolozza dei colori (la quarta 
colonna dell'ultima riga).

15.  Cliccare su OK del dialogo Color e quindi su quello del dialogo Style Definition.

16.  Sulla legenda, cliccare sul bottone destro sul punto USSampleImage.tif, e spengete l'opzione Locatable 
(=Selezionabile), cliccando sul relativo check.

Dato che l'immagine è utilizzata solo come sfondo, non è necessario poterla selezionare.

17.  Salvate il GeoWorkspace.

18.  Prima di procedere alla prossima sezione, osserviamo con più attenzione questa immagine.  è possibile 
utilizzare i comandi View > Zoom e View > Pan per vedere le diverse parti dell'immagine.  Quando sarete 
pronti per passare alla prossima sezione, riportate la scala di visualizzazione a 1:25,000,000, utilizzando 
Display Scale, e quindi cliccando su Apply e su Close.  

Se necessario, utilizza il comando View > Pan per centrare la mappa nella finestra.  (Per utilizzare il comando 
Pan , piazzare il cursore sulla mappa, premere e tenere premuto il tasto sinistro del mouse, e quindi muovere la 
mappa nel centro della finestra.)

19.  Salvare il GeoWorkspace.

Continua nella prossima sezione 3-Lavorare con la Legenda 
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 Lavorare con la Legenda

La Legenda è il centro di controllo interattivo di tutto quello che viene visualizzato nella finestra della mappa. Attraverso 
la legenda è possibile controllare la scelta degli oggetti da visualizzare (come classi di feature, immagini, risultati di 
interrogazioni, e visualizzazioni tematiche) e sceglierne l'aspetto. 

Nell'esercizio seguente, sceglieremo la scala minima e massima di visualizzazione per i toponimi degli stati (state-name 
labels).  Se la scala di visualizzazione corrente non cade nell'intervallo di visualizzazione scelto, i toponimi non saranno 
visualizzati. 

1.  Selezionare Legend > Properties.  

Nei passi seguenti, visualizzeremo i toponimi degli stati in funzione della scala.  In questo modo, se il fattore di 
zoom cade fuori dall'intervallo di visualizzazione, i toponimi non saranno visualizzati.

2.  Cliccare sulla cella della colonna Display corrispondente alla riga StateNameLabels 

3.  Cliccare sulla lista drop-down per aprirla.  

4.  Nella lista drop-down, è possibile vedere solo le opzioni On e Off: scorrete la lista con la freccia in basso in 
modo da far apparire l'opzione By Scale.

5.  Cliccate sul bottone Scale nell'angolo in basso a destra del dialogo (sempre nella pagina Entries ). 

Il dialogo Scale Range permetterà di scegliere l'intervallo di scala nel quale la feature sarà visualizzata.  

Nel momento in cui la scala di visualizzazione della mappa cadrà all'interno dell'intervallo desiderato per questo 
punto della legenda, l'oggetto corrispondente sarà visualizzato; in caso contrario l'oggetto sarà invisibile.

6.  Cambiare il valore Minimum in 2,000,000 (2 milioni).  

7.  Non cambiate il valore Maximum e cliccate OK.

Se avete zummato la mappa ad una scala minore di 1:2,000,000, i toponimi non saranno visualizzati.

Nota: Dopo aver selezionato l'opzione Display by Scale, una piccola barra di scala apparirà alla sinistra della 
feature nella legenda, in modo da indicare che la relativa caratteristica è visualizzata in funzione della scala. 
Questa caratteristica sarà visibile alla fine di questo esercizio, dopo aver chiuso il dialogo Legend Properties.

Proprietà generali della legenda

è possibile controllare le propietà generali di una legenda.   Questa caratteristica è particolarmente utile per incorporare le 
mappe generate in altri documenti (ad esempio documenti di testo). 

1.  Selezionare la pagine General nel dialogo Legend Properties.

Notate che gli attributi testo dei punti della legenda possono essere modificati singolarmente.   La casella 
denominata Example layout mostra un esempio di visualizzazione della legenda con le impostazioni attuali 
(titolo, sottotitolo e intestazione).

2.  Cambiate il testo Title in bold (=grassetto) cliccando sul bottone Title, selezionando l'opzione Bold e cliccando 
su OK nel dialogo Font.

3.  Selezionare quindi Show statistics (=Visualizza statistiche).

4.  Cliccare sul bottone OK per chiudere il dialogo e vedere le modifiche allo stile della legenda.

Adesso i punti della legenda sono visualizzati in grassetto, inoltre per ogni punto della legenda viene 
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visualizzato il numero di elementi presenti sulla mappa.

5.  A questo punto salvate il GeoWorkspace.

Continua nella prossima sezione 4-Mappe tematiche e gli oggetti della mappa
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 Mappe tematiche e gli oggetti della mappa

Una thematic map (=mappa tematica) utilizza colori e simboli per evidenziare la distribuzione e le caratteristiche spaziali 
delle feature all'interno della mappa. Questo viene ottenuto utilizzando gli attributi associati alle feature, i quali 
descrivono le caratteristiche comuni a gruppi di oggetti.  Un attributo è un'informazione non geografica memorizzata nella 
feature in aggiunta ai dati geometrici. I dati degli attributi sono visualizzati come colonne di una finestra dati, dove ogni 
cella di una colonna contiene un valore associato ad una particolare feature.

Prima di creare una mappa tematica, è necessario importare la feature States dalla connessione in sola lettura Connection 
to US Data alla connessione in lettura/scrittura learning (che abbiamo creato precedentemente).  Importiamo questi dati 
in modo da poterli modificare in seguito.  

Importazione dei dati da una Warehouse di tipo Access

Importare i dati vuol dire copiarli da una warehouse sorgente ad una destinazione.  è possibile importare i dati da una 
qualsiasi warehouse supportata da Geomedia in lettura ad una warehouse di tipo Access.

1.  Selezionare il menù Warehouse > Import from Warehouse (=Importa da una warehouse).  

2.  Leggere le istruzioni del dialogo Import Warehouse Wizard (=Il mago delle importazioni), e cliccare su Next
(=Prossimo).  

La warehouse source (=sorgente) è USSampleData.mdb, e quella target (=Destinazione) è learning.mdb.

3.  Quando viene chiesto Which connection do you want to use to access your source warehouse? (=Quale 
connessione vuoi usare per accedere alla tua warehouse sorgente?), seleziona la connessione Connection to US 
Data cliccando sul selettore della riga (il primo elemento a sinistra). 

4.  Cliccare su Next.

5.  Quando viene chiesto Which connection do you want to use to access your target warehouse? (=Quale 
connessione vuoi usare per accedere alla warehouse destinazione?), assicurarsi di aver selezionato la 
connessione chiamata learning  e cliccare su Next.

6.  In risposta al messaggio Select the feature class you want to import from the source warehouse then click 
the ">" button (=Seleziona la feature che vuoi importare dalla warehouse sorgente e clicca sul bottone ">"), 
seleziona la feature States dalla lista Import from source warehouse .  

7.  Cliccare il bottone ">" per trasferire la feature da importare nella parte destra del dialogo.  

Se è necessario apportare correzioni, è possibile utilizzare il bottone "<" per rimuovere alcune feature dalla lista 
di quelle da importare, che si trova nella parte destra del dialogo.

8.  Mantenendo la feature States visualizzata nel campo Import to target warehouse, cliccare sul bottone Next.  

9.  Cambiate il nome della feature States in ImportedStates, cliccando sul campo apposito e digitando il nuovo 
nome.  

10.  Cliccare su Next.

11.  Qunado viene chiesto What do you want to do? (=Cosa diavolo vuoi fare?), assicurarsi di aver selezionato 
l'opzione Create new legend entries(=Creare un nuovo punto della legenda).
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12.  Assicurarsi che la linea Active Map Window (MapWindow1) sia visualizzata nel campo Map windows for 
display (=Finestra della mappa per visualizzare), e cliccare su Finish.  

Apparirà il dialogo Import Statistics (=Statistiche di importazione), il messaggio Importing... verrà 
visualizzato per ogni feature importata.  La barra di stato indicherà lo stato di avanzamento dell'importazione, 
in particolare sarà visualizzato il numero di feature importate.  A processo completato il messaggio Import 
complete(=Importazione completata) rimpiazzerà il messaggio Importing...

13.  Cliccare su Close.

Gli oggetti della classe di features ImportedStates appariranno nella finestra della mappa.

Le feature ImportedStates e States sono identiche, eccetto il fatto che ImportedStates è una feature in lettura/
scrittura, mentre la feature States è in sola lettura.  Per il proseguimento di questo corso la feature States non 
sarà più necessaria, per cui si consiglia di spengerne la visualizzazione:

14.  Sulla legenda, cliccare col bottone destro sul punto States, quindi cliccare su Display Off.

15.  Elimina il punto States dalla legenda, cliccando di nuovo col bottone destro sul punto stesso e selezionando il 
comando Hide Legend Entry (=Nascondi il punto della legenda).

Nota: sebbene la feature States non sia visibile nella legenda e nella mappa, questa può essere rivisualizzata 
selezionando il menù Legend > Properties, quindi cliccando sulla colonna Entry e sulla riga States, e 
selezionando nel campo Display il valore On .  Per ora comunque lascia spenta la visualizzazione di questa 
feature.

Adesso setta la feature ImportedStates in modalità Size changes as display scale changes (true at nominal 
map scale), come era settata la feature originale States e utilizza lo stesso stile di questa feature.

16.  Seleziona il menù Legend > Properties.

17.  Seleziona il punto (cioè la riga) corrispondente a ImportedStates cliccando sul selettore di riga a sinistra della 
riga stessa.

18.  Clicca sul bottone Style nell'angolo in basso a destra della pagina Entries.

19.  Nella pagina Area Boundary (=Bordo delle Aree), clicca su Color.

20.  Seleziona il quadratino grigio scuro sulla tavolozza dei colori (la quarta colonna sull'ultima riga).

21.  Clicca su OK nel dialogo Color.

22.  Sempre nel dialogo Style Definition, togli il check all'opzione Size remains constant as display scale changes 
(=La dimensione rimane costante al variare della scala) (assicurasi cioè che questa opzione sia spenta).

23.  Clicca su OK nel dialogo Style Definition.

24.  Utilizza l'opportuna freccia Priority per spostare la riga ImportedStates in cima alla legenda.

25.  Clicca su OK nel dialogo Legend Properties.
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26.  Salvate il GeoWorkspace.

Creazione di una mappa tematica

Creeremo adesso una mappa tematica per visualizzare gli intervalli di valore dell'attributo annual snowfall (=Nevicate 
annuali), relative alla feature States.  Questo tipo di mappa tematica sarà per voi d'aiuto per scegliere in quale stato 
utilizzare gli impianti sciistici. 

Nota: Effettua le prime due operazioni solo se si è scelto di inserire l'immagine raster a riferimento USSampleImage.tif 
negli esercizi precedenti. 

1.  Prima di creare una mappa tematica, spegni la visualizzazione dell'immagine raster, cliccando col bottone destro 
sul relativo punto delle legenda e selezionando il comando Display Off.

L'immagine raster scomparirà dalla finestra della mappa.

2.  Nascondi adesso il punto della legenda relativo all'immagine raster, ricliccando col bottone destro sul punto 
corrispondente e selezionando Hide Legend Entry.

Il punto della legenda non sarà più visibile.
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3.  Seleziona il menù Legend > Add Thematic.

4.  Nel dialogo Add Thematic Entry, nella lista a discesa Feature class, clicca sul simbolo + vicino alla 
connessione denominata learning per aprire la lista delle feature contenute in questa connessione.  

5.  Seleziona l'unico elemento della lista: ImportedStates.

6.  Dalla lista Available attributes (=Attributi disponibili) che verrà visualizzata, selezionare l'attributo 
ANNULSNOW.

7.  Cliccare su Range (=Intervallo).

Questa opzione specifica il tipo di visualizzazione tematica da creare: l'opzione Unique (=Unico) si basa su una 
serie di valori unici ed individuali dell'attributo selezionato, mentre l'opzione Range si basa su di un'insieme 
predefinito di intervalli numerici.

8.  Cliccare su Define (=Definisci).

Apparirà il dialogo Map By Ranges. (=Mappa da intervalli)

9.  Cliccare su Rotate Color Schemes (=Ruota lo schema dei colori).

Apparirà una scala di colore. 

10.  Continuare a cliccare su Rotate Color Schemes fintanto che non sarà visualizzata una scala di colori che vi 
aggrada.  Comunque qualsiasi scala di colore può andar bene; è solo una scelta estetica.

11.  Cliccare su OK nel dialogo Map By Ranges.

12.  Cliccare su OK nel dialogo Add Thematic Entry.

La mappa tematica verrà visualizzata utilizzando la scala di colore selezionata. Tale mappa mostrerà le 
quantità di neve caduta per ogni stato, suddivise in intervalli di valore. I nome degli stati sono adesso coperti 
dalla mappa tematica .

13.  Clicca col pulsante destro in un punto qualsiasi della legenda e quindi scegli Properties.  

14.  Nel dialogo Legend Properties, seleziona il punto StateNameLabels (clicca sul selettore di riga), e quindi 
clicca sulla freccia di priorità massima per spostare StateNameLabels il cima alla lista.
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15.  Clicca su OK per chiudere il dialogo.

I toponimi degli stati riappaiono sulla finestra della mappa; ora infatti hanno una priorità maggiore delle altri 
punti della legenda.

IMPORTANTE: Le priorità di visualizzazione dei vari tipi di geometria possono migliorare la leggibilità e 
minimizzare le sovrapposizioni.  La configurazione tipica prevede di piazzare i toponimi in cima alla legenda, 
seguiti dai simboli, dalle linee, ed infine dalle feature areali.

16.  Salvate il GeoWorkspace. 

Suggerimento Animato—Schema a scala di colore

In questa sezione abbiamo creato una mappa tematica usando una schema di colore standard, che mostra una progressione 
di colori prefissata  è possibile invece applicare una schema che fa utilizzo di una scala di colore generata 
automaticamente a partire da una coppia di colori assegnati dall'utente.  Per applicare una scala di colore, bisogna 
utilizzare il tool Ramp Assigned Colors (=Scala i colori assegnati).

Se state usando Internet Explorer® version 4.0 o versione superiore, clicca col mouse 
sull'illustrazione seguente per vedere gli effetti dell'applicazione dei colori standard o di una scala 
di colori.  Nota: per un miglior risultato, massimizza la finestra del visualizzatore prima di vedere 
le animazioni.  Ripristina quindi le dimensioni originali dopo aver visto l'animazione. 
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Selezionare gli Oggetti della Mappa

Gli oggetti della mappa vanno selezionati per informare Geomedia professional che si vuole applicare ad essi un 
particolare comando, tipo sposta, edita o cancella. 

1.  Assicurarsi che il tool Select (=Seleziona) della barra degli strumenti sia attivo.

Il cursore all'interno della finestra della mappa diventa una freccia con un indicatore all'estremità.

L'indicatore di zona di selezione è un'area circolare sulla punta del cursore, che definisce l'intervallo entro il 
quale gli oggetti sono localizzati.  La dimensione della zona di selezione può essere settato utilizzando il menù 
Tools > Options > SmartLocate (=Localizzazione Intelligente); per ora comunque lasciamolo com'è

2.  Muovete il cursore sopra alcuni degli stati della mappa degli USA senza però cliccare su niente. 

Notate che quando il cursore passa su uno stato o su un toponimo, questi oggetti vengono visualizzati con un 
altro colore.  Questo colore è il cosiddetto colore di highlight (=Evidenziato), il quale indica che l'oggetto è stato 
localizzato.

3.  Muovete il cursore sopra ogni stato, come ad esempio la Florida.

Lo stato verrà evidenziato.

4.  Cliccate adesso col bottone sinistro del mouse.

Notate che lo stato ha assunto ora un colore diverso ancora.  Questo è il cosiddetto colore di selezione, che sta 
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ad indicare che l'oggetto è stato selezionato.

Nota: Se appare il dialogo PickQuick (=Chiappa veloce), chiudetelo e selezionate lo stato un'altra volta.

I colori di highlight e di selezione possono essere modificati.

5.  Seleziona il menù Tools > Options.

6.  Nella pagina Map Display, selezionate il colore che preferite per le opzioni Select e Highlight.

7.  Dopo aver selezionato i colori, cliccate su OK per uscire dal dialogo Options.

8.  Tenete premuto il tasto CTRL e cliccate su due o tre toponimi di stato .  Notate che adesso sono tutti selezionati.

I tasti CTRL e SHIFT permettono di selezionare più oggetti contemporaneamente, con un funzionamento simile 
a molte altre applicazioni. Questi oggetti verranno posti nell'insieme selezionato.

Un insieme selezionato è costituito da uno o più oggetti della mappa selezionati contemporaneamente.  

9.  Per vedere come si seleziona un oggetto sovrapposto ad altre oggetti, muovete il cursore sul toponimo dello 
stato del Texas.

10.  Tenete fermo il mouse: dopo alcuni secondi potrete vedere che accanto al cursore del mouse sono apparsi tre 
punti.  

I punti di sospensione indicano che nell'area considerata ci sono più oggetti sovrapposti.  In questo caso, gli 
oggetti sono il toponimo e lo stato (area) a cui si riferisce.

11.  Quando compaiono i punti di sospensione, non muovete il mouse, e cliccate col bottone sinistro.  

Apparirà il dialogo Pick Quick (=Chiappa veloce) , il quale permette di selezionare il particolare oggetto di 
nostro interesse da un'area sovraffollata di oggetti. 

Per quanto riguarda l'area che abbiamo selezionato, ci sono nel dialogo Pick Quick tre punti: il primo 
(corrispondente al numero 1) è il toponimo dello stato, il secondo (numero 2) è lo stato visualizzato nella mappa 
tematica, e il terzo è lo stato vero è proprio, che sembra coincidere con l'oggetto del punto 2..

12.  Muovete il cursore del mouse sopra ogni bottone numerato del dialogo, e osservate quale degli oggetti della 
mappa verrà evidenziato.

13.  Cliccate adesso sul numero 2 oppure sul 3, che corrispondono agli stati.

Lo stato sarà selezionato. 

Rivedere le proprietà delle feature

è possibile visualizzare il dialogo Properties (=Propietà) per vedere ed editare le propietà delle feature. 

1.  Mantenendo selezionato lo stato del punto precedente, selezionate il menù Edit > Select Set Properties 
(=Proprietà dell'insieme selezionato).

Apparirà il dialogo ImportedStates Properties.

Questo dialogo mostra le informazioni generali circa le feature selezionate (lo stato del Texas), e visualizza il 
nome ed il valore degli attributi non grafici associati alla feature, come ad esempio la population (=popolazione) 
o l' annual snowfall (=precipitazioni annuali di neve). 

2.  Selezionare la pagina strong>General.

Ricordate che l' Area è in metri quadrati.

Nota: è possibile trascinare il lato sinistro della colonna Value per vedere l'intero valore degli attributi.
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3.  Cliccare su Cancel per chiudere il dialogo.

4.  Selezionate il menù Tools > Options.

5.  Selezioante la pagina Units and Formats (=Unità di misura e formati).

6.  Nel campo Type (=Tipo), selezionate Distance (=Distanza).  Nel campo Unit (=Unità di misura), selezionate 
mi dalla lista per selezionare le miglia come unità di misura delle distanze su terra.

7.  Selezionate Area nel campo Type, e quindi mi^2 (miglia quadrate) dalla lista Unit.

8.  Cliccate su OK.

9.  Selezionate il menù Edit > Select Set Properties (oppure fate doppio click sullo stato del Texas).

10.  Selezionate la pagina General.

L'are adesso sarà espressa in miglia quadrate.

11.  Cliccate ancora su Cancel per chiudere il dialogo ImportedStates Properties.

12.  Salvate il GeoWorkspace.

Continua nella prossima entusiasmante sezione 5-Usare la Data Window
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 Usare la "Data Window" (=Finestra dei dati)

è possibile visualizzare una data window (=Finestra dati), per vedere gli attributi di ogni feature della classe 
ImportedStates.  Una finestra dati è una finestra di visualizzazione in formato tabellare, che mostra i dati non geografici di 
una feature. 

Aprire una Data Window

1.  Selezionare il menù Window > New Data Window.

2.  Nel dialogo New Data Window (=Nuova finestra dati), mantieni il nome proposto DataWindow1 come nome 
della nuova finestra, e seleziona la riga ImportedStates dalla connessione learning.   

3.  Cliccare su OK.

In questo modo apparirà una nuova finestra dati, contenente una riga di attributi per ogni feature della classe 
states.

4.  Per vedere la mappa insieme ai dati, selezionare il menù Window > Tile Horizontally.

5.  Per visualizzare gli oggetti della finestra dati, ordinati per nome di stato, selezionare la colonna 
STATE_NAME cliccando sull'intestazione della colonna stessa.

La colonna si illuminerà. 

6.  Selezionare il menù Data > Sort Ascending (=In ordine crescente).  

Gli elementi saranno ordinati per nome di stato.

7.  Per centrare la mappa dell'intera America nella finestra, attivate la finestra della mappa (cliccandoci sopra), e 
selezionate il menù View > Pan.

8.  Tenendo il puntatore del mouse sulla mappa, premete e mantenete premuto il bottone sinistro del mouse, quindi 
muovete la mappa in modo da centrarla sulla finestra.

Assicuratevi che la maggior parte della mappa sia visibile, anche se alcune parti saranno coperte dalla legenda, 
mentre altre cadranno fuori dai bordi della finestra.

9.  Premete il tasto ESC per uscire dal comando Pan.

10.  Selezionate adesso una riga della finestra dati, cliccando sulla parte sinistra della tabella.   

Lo stato corrispondente sarà evidenziato nella finestra della mappa.  

11.  Selezionate invece un qualsiasi stato nella finestra della mappa (cliccandoci sopra).
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La riga corrispondete nella finestra dati verrà evidenziata.

Abbiamo mostrato come sia possibile selezionare le feature sia sulla finestra della mappa, sia sulla finestra dati.

12.  Nella finestra della mappa, cliccate sul selettore della tabella (il rettangolino in alto a sinistra), per selezionare 
l'insieme di tutti gli stati degli USA.

Tutti gli stati della mappa verranno selezionati.

Aggiornamento dinamico della visualizzazione dei dati

Vedremo adesso come Geomedia Professional aggiorni dinamicamente la visualizzazione in presenza di modifiche dei 
dati.   Vedremo questa caratteristica modificando i dati della feature ImportedStates, dato che questa si trova in una 
connessione di lettura-scrittura. 

1.  Nella finestra dati, cliccare sulla riga contenente lo stato dell' Alabama (che dovrebbe essere la prima riga in 
ordine alfabetico).

Lo stato dell'Alabama verrà evidenziato anche nella finestra della mappa.

2.  Assicurarsi che lo stato dell'Alabama sia visibile nella finestra della mappa.  Se lo stato non fosse visibile, 
attivate il comando Pan e muovete la mappa finché questo non diventi visibile (anche parzialmente).

3.  Nella finestra della mappa, deselezionate lo stato dell'Alabama, cliccando in un punto vuoto qualsiasi, in modo 
da poter vedere il colore di questo stato nella mappa tematica.

4.  Nella finestra dati, scrollate a destra finché non raggiungete la colonna ANNULSNOW.

Il valore di questa colonna, per lo stato dell'Alabama è 1, quindi nella mappa tematica lo stato e visualizzato con 
lo stesso colore degli stati adiacenti.

5.  Cambiare il valore di questo attributo nella finestra dati, modificandolo in 40: cliccate nella cella corrispondente 
alla colonna ANNULSNOW della riga Alabama e digitate il nuovo valore 40.  

6.  Dopo aver digitato il nuovo valore, cliccate su di una qualsiasi altra cella, per confermare il valore.

7.  Adesso osservate la finestra della mappa e notate che il colore dello stato dell'Alabama è stato modificato per 
rispecchiare il cambio del valore dell'attributo.   

Come potete vedere, la visualizzazione tematica di GeoMedia viene aggiornata automaticamente, per 
rispecchiare le modifiche nei dati.  Anche nelle query, come vedremo più avanti, Geomedia memorizza la 
definizione della query, ma non i suoi risultati.   In questo modo, ogni volta che si visualizza una query, i 
risultati verranno ricalcolati secondo il valore corrente dei dati, dando in questo modo alle query un 
funzionamento dinamico. 

8.  Chiudete adesso la finestra dati.

9.  E massimizzate la finestra della mappa.

10.  Selezionate il menù View > Pan per assicurasi che la mappa sia adattata nella finestra. 

11.  Spengete la visualizzazione della mappa tematica, cliccando col tasto destro sul punto della legenda denominato 
ImportedStates by ANNULSNOW, e selezionando il menù Display Off.

12.  Eliminate il punto stesso della legenda, cliccando di nuovo col bottone destro e selezionando il menù Hide 
Legend Entry.

La mappa tematica non sarà più visualizzata.

13.  Salvate adesso il GeoWorkspace.
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Dare un nome alla legenda

Adesso potete dare un nome alla legenda per la mappa degli USA.  Dare un nome ad una legenda permette di utilizzare 
questa legenda per altre mappe dello stesso GeoWorkspace.  Supponendo di avere le stesse classi di feature, queste 
saranno visualizzate con la stessa simbologia della legenda con nome. 

1.  Selezionare il menù Legend > Name Legend(=Dai un nome alla legenda).

2.  Nel campo Name, digitare LearningLegend1.

3.  Cliccare su OK.

Manipolare la visualizzazione

Creeremo adesso un'altra finestra-mappa, in cui visualizzeremo i nostri risultati da vicino.   In questa nuova mappa, 
zummeremo sugli stati del Minnesota e del Wisconsin (che di trovano in alto al centro degli USA); questa zona 
corrisponde a quella che contiene i risultati finali della selezioni degli impianti sciistici.

Prima di aprire la nuova finestra della mappa, è opportuno dare alla mappa corrente un nome più significativo. 

1.  Selezionare il menù Window > Map Window Properties (=Propietà della mappa).

2.  Nel campo Map window name(=Nome della mappa), digitare US Map.  

3.  Cliccare sul bottone OK.

4.  Selezionare adesso il menù Window > New Map Window (=Nuova mappa) per aprire una nuova finestra della 
mappa.

5.  Nel dialogo New Map Window, chiamare la nuova mappa col nome di Final Counties.

6.  Selezionare quindi come legenda LearningLegend1.  

7.  Cliccare su OK.

La nuova finestra della mappa, denominata Final Counties, sarà visualizzata.

8.  Selezionare il menù View > Zoom > In.

Potrete così zoommare in avanti nella regione ovest degli Stati Uniti.

9.  Piazzare il cursore del mouse (col il simbolo di zoom) al centro dello stato del North Dakota (situato nella zona 
centrale a nord degli Stati Uniti).

10.  Premere e mantenere premuto il tasto sinistro del mouse, disegnate un rettangolo fino all'angolo estremo 
dell'Ohio.
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5-Usare la Data Window

11.  Rilasciate quindi il tasto sinistro del mouse.

La vista sarà zummata.

12.  Premete quindi il tasto ESC per uscire dal comando di Zoom.

Nota: I toponimi degli stati e dei confini saranno visualizzati più grandi a questa nuova scala (visibile nella 
barra di stato).   Questi oggetti sono visualizzati più grandi perché si è scelta l'opzione Size changes as display 
scale changes (true at nominal map scale) che significa: la dimensione cambia quando cambia la scala di 
visualizzazione.

13.  Salvate il GeoWorkspace.

Continua alla prossima sezione 6-Costruzione delle interrogazioni
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 Costruzione delle interrogazioni

Una query(=interrogazione) e' una richiesta di informazioni.  Quando si visualizza una query, si visualizza un'insieme di 
feature che corrispondono ad uno specifico criterio di scelta.  Con GeoMedia Professional, e' possibile costruire una query 
in modo grafico, selezionando le opzioni da un dialogo, senza aver bisogno di conoscere il linguaggio SQL.  

Le query presentano sempre le informazioni corrente della warehouse.  Questo significa che ogni volta che la query e' 
visualizzata, questa mostra le informazioni aggiornate della warehouse.

Costruire una Query

Per prima cosa creeremo una query di filtro sugli attributi, che ci permettera' di selezionare dal database alcune feature, a 
cui sono assiciati particolari valori di attributi, oppure intervalli di valore.  La feature utilizzata sara' ImportedStates. 

Vogliamo evidenziare quali stati hanno un'alta percentuale di nevicate e una bassa temperatura media, cosa che rende uno 
stato un buon candidato per ospitare una stazione sciistica. 

1.  Selezionate il menu0 Analysis > New Query per visualizzare il dialogo New Query.

2.  Cliccare su Options all'interno del dialogo.

3.  Assicurarsi che le opzioni Active window(=Finestra attiva) e Confirm show value operations (=Chiedi 
Conferma per Visualizza Valori) siano selezionate.

Quando l'opzione Confirm show value operations e' selezionate, verra' visualizzato un messaggio quando 
viene premuto il bottone Show Values (=Visualizza valori) del dialogo Filter.  Questo messaggio informa che 
la visualizzazione di tutti i valori puo' risultare molto lenta.

4.  Cliccare su OK.

5.  Dalla lista Select Features in (=Seleziona feature da...), aprire la connessione learning.  Dalla lista seguente, 
selezionare la feature ImportedStates.

6.  Cliccare sul bottone Filter per visualizzare il dialogo che permette la definizione del filtro per la feature 
selezionata (ImportedStates).

Sara' possibile specificare quale sotto-insieme delle feature sara' visulizzato specificando il filtro usato.  

7.  Selezionate ANNULSNOW (nevicate annuali) dalla lista degli attributi.

8.  Cliccare sulla freccia verso il basso, che si trova sotto il campo Attributes.

L'attributo , ANNULSNOW, apparira' nel campo Filter.

Nota: invece di cliccare sulla freccia, e' possible fare direttamente doppio click sul valore della lista.

9.  Selezionare l'operatore "maggiore di" (>).

L'attributo e l'operatore appariranno nel campoFilter in fondo al dialogo.  E' possibile, in alternativa, digitare 
direttamente una clausola SQL in questo campo.

10.  Cliccare il bottone Show Values (=Mostra valori).  

11.  Se viene chiesto la conferma per continuare, cliccare su Yes.

12.  Dalla lista di valori che appare, selezionare 40 e cliccare sulla freccia verso il basso che si trova sotto il campo 
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Values.

Nel campo Filter verra' visualizzata l'espressione ANNULSNOW > 40.

13.  Selezionate ora l'operatore AND (=e).  

14.  Selezionare l'attributo AVETEMP (average temperature=Temperatura Media), e cliccare sulla freccia sotto il 
campo Attributes.

15.  Selezionare l'operatore "minore di" (<).

16.  Digitare il valore 50 alla fine dell'espressione, nel campo Filter.

L'espressione ANNULSNOW > 40 AND AVETEMP < 50 dovra' essere visualizzata nel campo Filter.

17.  Cliccare su OK nel dialogo ImportedStates Filter.

18.  Nel campo Name del dialogo New Query, digitare States by Snow/avetemp.  

E' sempre una buona idea, quella di dare alle vostre query un nome descrittivo, dato che cosi' e' facile ricordarsi 
la sua definizione.  

19.  Cliccare su OK per visualizzare i risultati della query.

La query verra' aggiunta alla legenda.  Il punto della legenda corrispondente alla query contiene l'icona dello 
stile, che tralaltro mostra il colore utilizzato nella mappa per visualizzare il risultato della query stessa. 

In realta', puo' essere difficile vedere i risultati della query appena fatta.  I bordi della feature ImportedStates 
sono in questo momento piu' spessi di quelli della query, dato che sono in modalita' Size changes as display 
scale changes (true at nominal map scale).  Per vedere meglio la query, cambieremo il suo stile nel prossimo 
esercizio.

Cambiare lo stile degli Oggetti della Mappa

Il dialogo Style Definition (=Definizione dello stile) ci permette di modificare l'aspetto degli oggetti della mappa, come 
ad esempio le classi di feature, le immagini, i risultati delle query e le visualizzazioni tematiche. 

1.  Per cambiare lo stile, utilizziamo una scorciatoia: fatte doppio click sull'icona dello stile del punto della legenda 
interessato, vale a dire la query States by Snow/avetemp.

Verra' visualizzato il dialogo Style Definition.  La pagina Area Boundary (=Bordo dell'area) mostra colore, 
spessore e stile di linea per i bordi degli oggetti.   

2.  Selezionare la pagina Area Fill(=Riempimento dell'area).  

3.  Dalla lista Type, selezionare Solid.

4.  Selezionate il colore primario di riempimento, cliccando sul bottone Color e quindi scegliendo un colore, ad 
esempio celeste. 

5.  Cliccare su OK per chiudere il dialogo Color.

6.  Dalla lista Pattern(=Motivo), selezionare un motivo, ad esempio Trellis.

Un esempio del motivo selezionato apparira' nell'area Sample(=Esempio).

7.  Scegliete un altro colore per Cross-hatch color, se volete.

8.  Smarcate l'opzione Size remains constant as display scale changes in modo che questa opzione non sia piu' 
selezionata.
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9.  Cliccare su OK quando avete scelto uno stile che vi aggrada.

Il risultato della query States by Snow/avetemp apparira' adesso sulla mappa con lo stile che avete scelto.

I toponimi degli stati saranno adesso coperti dal risultato della query.  E' possibile utilizzare una scorciatoia per 
cambiare la priorita' di visualizzazione dei toponimi, in modo che questi siano visualizzati sopra la query.

10.  Selezionate nella legenda il puntoStateNameLabels, quindi utilizzano il mouse trascinatelo in cima alla 
legenda. 

I toponimi degli stati, appariranno sopra l'area della query.

11.  Save the GeoWorkspace.

Animated Tip Utilizzare motivi fatti di simboli

Nell'esercizio precedente, abbiamo selezionato un motivo per i risultati della query (che in questo caso erano aree).  Il 
dialogo Style Definition permette anche di assegnare motivi agli elementi lineari.  In aggiunta, sia per le linee che per le 
aree, e' possibile utilizzare motivi ripetuti costituiti da simboli.

If you are using Internet Explorer® version 4.0 or higher, click the mouse on the following 
illustration to see an example of using a symbol in a line pattern.  The illustration shows using a 
symbol that is, and is not, offset from the line. 

Definizione di un filtro spaziale

Uno spatial filter (=Filtro spaziale) definisce un'area della finestra della mappa.  Utilizzando un filtro spaziale, saranno 
visualizzate (e accessibili) solo quelle feature che cadono nell'area definita.  Il filtro spaziale e' opzionale, ma ne 
definiremo uno in questo esercizio per vedere le feauture di solo due stati. 

Ad esempio, supponiamo di focalizzare la nostra attenzione sugli stati del Minnesota e del Wisconsin, come possibili 
destinatari di impianti sciistici. 
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1.  Selezionate il menu' Warehouse > Define Spatial Filter by Fence (=Definisci un filtro spaziale a partire da 
una recinzione).  

Il cursore si modifichera' in una croce.

Per definire il filtro, piazzate un rettangolo che contiene il bordo dei due stati, Minnesota e Wisconsin, come 
mostrato qui di seguito. 

Il rettangolo include anche parti di altri stati, come ad esempio il Michigan; vedremo in seguito come 
modificare la query per ottenere solo le feature contenute esattemente nei due stati scegli.

2.  Piazzate il primo punto nell'angolo in alto a sinistra del rettangolo sopra lo stato del Minnesota.  

3.  Premete e mantenete premuto il tasto sinistro del mouse, quindi trascinate il cursore fino all'angolo in basso a 
destra dello stato del Wisconsin, per definire l'angolo opposto del rettangolo.  Release the mouse button.

Apparira' il dialogo New Spatial Filter (=Nuovo filtro spaziale).

4.  Nel campo Filter name, digitate Minnesota and Wisconsin.  

5.  Selezionate il valore Overlap (=Sovrapposizione) nel campo Spatial operator(=Operatore Spaziale).

6.  Togliete la marca all'opzione Apply to GeoWorkspace.  Mantieni invece marcata l'opzione Set as default 
filter for existing connections.

L'opzione Apply to GeoWorkspace permette di applicare il filtro spaziale a tutti i punti gia' esistenti della 
legenda.  Se invece si vuole mantenere questi punti come sono e si vuole applicare il filtro spaziale solo ai nuovi 
punti, bisogna settare l'opzione Set as default filter for existing connections.  

7.  Cliccate su OK.

La visualizzazione del filtro sara' eliminata: abbiamo comunque creato il nuovo filtro.

La prossima volta che aggiungerete una feature od una query, verrano visualizzati solo i risultati che cadranno 
all'interno del filtro appena definito. 

Aggiungere una Classe di Feature

Aggiungeremo addesso alla visualizzazione, tre feature dalla nostra warehouse in sola lettura.
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1.  Selezionate il menu' Legend > Add Feature Class (=Legenda, Aggiungi Feature).

2.  Nel dialogo Add Feature Class Entry, assicurarsi di aver selezionato la connessione Connection to US Data.

3.  Tenete premuto il tasto CTRL e selezionate Cities, Counties, e Interstates dalla lista delle feature.

4.  Cliccate su OK.

I punti cities, counties, e interstates saranno aggiunti alla legenda, saranno visualizzate comunque solo quelle 
feature che cadranno dentro il filtro spazialew.

Come potete vedere, usare il filtro spaziale risulta conveniente per vedere solo le porzioni di dati che ci 
interessano in questo momento.

5.  Spengete la visualizzazione dei nuovi punti Cities eCounties selezionandoli entrambi nella legenda (tenendo 
premuto il tasto CTRL), quindi cliccando col bottone destro e selezionando il menu' Display Off.

6.  Nascondete quindi i punti della legenda Cities eCounties cliccando sempre col bottone destro su questi oggetti 
della legenda e selezionando la voce Hide Legend Entry.

7.  Spostate il punto StateNameLabels in cima alla legenda trascinandolo col cursore (in modo che si trovi sopra le 
strade e le altre feature della legenda).

Costruzione di un'altra query

Addesso creeremo un'altra query sugli attributi per cercare le citta' piu' grandi fra quelle comprese nel filtro spaziale.  

1.  Selezionate Analysis > New Query per visualizzare il dialogo New Query.

2.  Dalla lista Select Features in, selezionate Cities dalla connessione Connection to US Data. 

3.  Cliccate sul bottone Filter per visualizzare il dialogo Cities Filter.

4.  Selezionate POP (popolazionbe) dalla lista degli attributi, quindi cliccate sulla freccia sotto la lista.

5.  Selezioante l'operatore "maggiore di" (>).

L'attributo e l'operatore appariranno nel campo Filter. 
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6.  Digitate quindi il valore 100000 direttamente nel campo Filter.

Verra' visualizzata quindi l'espressione POP > 100000 nel campo Filter.

7.  Cliccate su OK nel dialogo Cities Filter.

8.  Nel campo Name del dialogo New Queryx, digitate Major Cities (=Citta' maggiori).  

9.  Cliccate su OK per visualizzare la query.

I risultati della query appariranno nella finestra della mappa. 

Notate che appariranno solo le citta' che soddisfano i criteri scelti e contemporaneamente cadono nell'area 
definita dal filtro spaziale.

Modifica di una Query

Adesso modificheremo la query Major Cities per includere solo le citta' del Minnesota e del Wisconsin.

1.  Selezionate il menu' Analysis > Queries per visualizzare il dialogo Queries.

2.  Dalla lista delle query, selezionate Major Cities.

3.  Cliccate su Edit (=Modifica).

4.  Nel dialogo Edit Query, cliccate su Filter.

5.  Nel dialogo Cities Filter, cliccate dentro il campo Filter, subito dopo la stringa da modificare: POP > 100000.

6.  Cliccate quindi su l'operatore AND (=E, nel senso della congiunzione).  

7.  Cliccate sull'operatore "parentesi" ().

8.  Muovete il punto di inserimento dentro le parentesi.  quindi selezionate (in ordine):

- L'attributo STATE_NAME
- La freccia in basso (sotto la lista)
- L'operatore "uguale a" (=)
- Show Values 
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- Yes in risposta al messaggio
- MINNESOTA dalla lista dei valori
- La freccia in basso
- L'operatore OR (=O, nel senso della congiunzione)
- L'attributo STATE_NAME
- La freccia in basso
- L'operatore "uguale a" (=)
- WISCONSIN dalla lista dei valori
- La Freccia in basso

Si dovra' leggere il filtro POP > 100000 AND (STATE_NAME = 'MINNESOTA' OR STATE_NAME = 
'WISCONSIN').

IMPORTANTE: Controllate accuratamente che il testo contenuto nel campo Filter corrisponda esattamente al 
testo mostrato qui sopra.  Se non dovesse corrispondere, non sara' possibile continuare correttamente il resto di 
questo corso.

9.  Cliccate su OK per chiudere il dialogo.  

La query verra' aggiornata con il filtro appena descritto. 

10.  Cliccate OK per visualizzare la query query.

I risultati della query verranno aggiornati per includere solo le citta' principali degli stati Minnesota e 
Wisconsin.

11.  Cliccate su Close nel dialogo Queries.

12.  Salvate il GeoWorkspace. 

Assegnare una vestizione alle Citta' Principali

Possiamo assegnare una vestizione alla query Major Cities in modo da evideziare queste citta'. 

1.  Fate doppio click sul simbolino dello stile del punto Major Cities della legenda.

2.  Selezionate Symbol dalla lista Type.

3.  Cliccate su Browse per aprire il file dei simboli transportation.fsm.
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Di default, i file dei simboli sono situati nella cartella GeoMedia\Symbols.

4.  Dalla lista Symbol, selezionate City Symbol #4.

5.  Mantenete selezionate le opzioni Use original symbol colors eSize remains constant as display scale changes.

6.  Cliccate su OK.

7.  Fate doppio click sull'icona dello stile del punto Interstates.

8.  Cambiate la simbologia di questa feature in questo modo: in Color selezionate un rosso, come Weight 
selezionate 2.00, quindi cliccate su OK.

9.  Spostate il punto StateNameLabels in cima alla legenda, seguito da Major Cities, Interstates, States by Snow/
Avetemp, e ImportedStates.

10.  Salvate il GeoWorkspace.

Continua nella prossima sezione 7-Buffer Zones, Queries Spaziali e Join
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 Buffer Zone(=Zona Cuscinetto), Querie Spaziali e Join

In questa sezione, piazzeremo una buffer zone (=Zona Cuscinetto) intorno ai risultati delle query.  Una buffer zone e' una 
regione, definita dall'utente, posta intorno ad una o piu' feature.  In seguito, creeremo alcune query spazial, che 
visualizzeranno informazioni del database circa due classi di feature o query; queste informazioni saranno basate su 
relazioni spaziali fra coppie di classi.  Infine, mostreremo le capacita' di GeoMedia Professional di realizzare join 
(=Unioni).

Inserimento di una Buffer Zone

Una buffer zone e' un'area posta intorno ad una feature (o posta fra due feature), su cui e' possibie effettuare analisi di tipo 
spaziale.  Le buffer zone sono generate come nuove feature, e, di solito, una nuova classe di feature e' automaticamente 
create e memorizzata nella warehouse di lavoro, per immagazzinare la buffe zone.  In questo esercizio, piazzeremo una 
buffer zone in un intorno di 90 miglia dalle citta' principali.  Questa buffer zone sara' quindi memorizzata nella warehouse 
learning. 

1.  Selezionare il menu' Insert > Buffer Zone. 

2.  Dalla lista Buffer zone around(=Zona cuscinetto intorno a...), aprire Queries, e selezionare Major Cities 
(=Citta' principali).

3.  Nel rettangolo Output buffer zone to, assicurarsi che il campo Warehouse sia settato a learning.  

4.  Nel campo Feature class, digitare ZoneAroundMajorCities (senza spazi!).  

Questo sara' il nome della buffer zone.

5.  Cliccare sul bottone Style.  

6.  Nella pagina Area Boundary, all'interno del rettangolo Primary line, cambiare il campo Color con un colore a 
vostra scelta, ad esempio arancione, e cliccare su OK nel dialogo Color.

7.  Cambiare il campo Weight (=Spessore) in 2.00.  

8.  Cliccare su OK nel dialogo Style Definition.

9.  Nel campo Constant distance (=Valore di Distanza), digitare il valore 90.

10.  Assicurarsi che all'interno del Buffer Type, il campo Point sia settato a Single, e che l'opzione Merged 
(=Unificata) sia settata per creare una buffer zone unificata.  

11.  Cliccare su OK.

La buffer zone apparira' nella finestra della mappa.

12.  Per rendere piu' evidente la visualizzazione della buffer zone, spengete la visualizzazione della query States by 
Snow/avetemp cliccando col bottone destro sul relativo punto della legenda e selezionando Display Off.  

13.  Nascondete il punto della legenda, cliccando sempre col bottone destro su States by Snow/avetemp nella 
legenda e selezionando Hide Legend Entry.
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14.  Save the GeoWorkspace. 

Costruire una query utilizzando la Buffer Zone

Creeremo adesso due nuove query.  Queste query saranno query spaziali, vale a dire che richiederanno al database 
informazioni circa la relazione spaziale che intercorre fra due feature o fra due altre query.

La prima query permettera' di trovare tutte le province scarsamente popolate che cadono entro la buffer zone appena 
creata.  Queste province potrebbero essere delle buone candidate per il posizionamento di impianti sciistici. 

1.  Selezionare il menu' Analysis > New Query.

2.  Dalla lista Select Features in, selezionare Counties (=Province) dalla connessione Connection to US Data.

3.  Cliccare su Filter per visualizzare il dialogo Counties Filter (=Filtro delle province).

4.  Selezionare POP(Popolazione) dalla lista degli attributi, e cliccare sul bottone con la freccia verso il basso.

5.  Selezioanre l'operatore "minore di" (<).

6.  Digitare il valore 30000 direttamente nel campo Filter.

La scritta POP < 30000 sara' visualizzata nel campo Filter.

7.  Cliccare su OK nel dialogo Counties Filter.

8.  Cliccare sul bottone Spatial del dialogo New Query.

Il dialogo si espandera'.

9.  Nel campo That(=che...), selezionare dalla lista are contained by (=... sono contenute in).

10.  Nel campo Features in, selezionare la buffer zone appena creata, ZoneAroundMajorCities, dalla connessione 
learning.

11.  Nel campo Name, digitare Small Counties Around Major Cities (=Piccole province intorno alle 
citta' maggiori).  

12.  Cliccare su OK per visualizzare la query.
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Le province che cadono nella buffer zone saranno visualizzate nella finestra della mappa.

NOTA: Avrete piu' province o meno a seconda della dimensione del filtro spaziale.

13.  Salvate il Geoworkspace.

Costruire query basate su altre query

Adesso cotruiremo un'altra query per cercare tutte le province della query precedente che si trovano pero' anche entro 9 
miglia da una strada statale (=intersate). 

1.  Selezionare il menu' Analysis > New Query per creare quest'ultima query.

2.  Dalla lista Select Features in, aprire Queries, e selezionare la query appena creata: Small Counties Around 
Major Cities. 

3.  Cliccare sul bottone Spatial.

4.  Nel campo That, selezionare dalla lista are within distance of (=...sono entro la distanza di...).

5.  Digitare il valore 9 (vale a dire 9 miglia) nel campo Distance.

6.  Nel campo Features in, selezionare la classe Interstates (=Strade statali) dalla connessione Connection to US 
Data.

7.  Battezzate questa query col nome di Final Counties.  

8.  Cliccate su OK per visualizzare la query.

I risultati della query saranno visualizzati nella finestra della mappa, anche se e' abbastanza difficile vederli 
dato che la query Small Counties Around Major Cities e' ancora visualizzata.

9.  Spengete la visualizzazione di quest'ultima query in modo da vedere con piu' chiarezza il risultato di Final 
Counties query.   (Cliccate col bottone destro su Small Counties Around Major Cities, e selezioante Display 
Off.)

10.  Nascondete quindi il punto della legenda, cliccando col bottone destro sempre su Small Counties Around 
Major Cities e selezionando Hide Legend Entry.

Adesso e' facile vedere i risultati della query Final Counties (dovrebbero esser 6 province).
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11.  Salvate il GeoWorkspace.

Creare una Join (=Giuntura)

Le join permettono di creare relazioni fra due feature o query, in modo che gli attributi di ogniuno dei componenti siano 
unificati in un'unica query risultato.

Creeremo una join delle sei province della query Final Counties in modo da vedere le informazione delle province 
insieme a quelle dei relativi stati, in cui le province sono situtate. 

1.  Selezionare Analysis > Join.

2.  Nel dialogo Join, selezionare la query Final Counties dalla lista Left side of join(=Lato sinistro della giuntura).

3.  Selezionare la feature ImportedStates dalla connessione learning nel campo Right side of join(=Lato destro 
della giuntura).

4.  Da entrambi (destro e sinistro) i campi Available attributes, selezionare l'attributo STATE_NAME,da cui la 
join sara' creata.

5.  Cliccare sulla freccia verso il basso per aggiungere la coppia di attributi al campo Selected attribute pairs 
(Coppie di attributi selezionati).

Nel campo Selected attribute pairs , apparira' il punto STATE_NAME/STATE_NAME.

6.  Assicurarsi che nel campo Type of join (=Tipo gi giuntura) sia selezionato il valore Inner (=Interna).

Nota: Per informazioni sui vari tipi di join, consultate il manuale di Geomedia Professional, oppure un buon 
manuale di SQL.

7.  Lasciate il nome proposto Join of Final Counties and ImportedStates, nel campo Query name.

8.  Assicurarsi che l'opzione Display join in data window(=Visualizza la join nella finestra dati) sia selezionata.

I risultati della join si possono visualizzare solo nella finestra dati.
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9.  Mantieni come nome della finestra DataWindow1.  

10.  Clicca su OK.

La join verra' visualizzata col titolo di Join of Final Counties and ImportedStates nella finestra dati.  
Verranno visualizzati sei record, uno per ogni privincia.  

11.  Fai scorrere la finestra dati verso destra per vedere tutti gli attributi. 

I dati sono visualizzati per prima cosa a partire da quelli delle province, quindi di seguito quelli riguardanti gli 
stati che contengono le province.  Alcuni attributi derivanti dagli stati hanno un 1 giustapposto al nome della 
colonna, per differenziarli da quelli derivanti dalle province stesse, che hanno lo stesso nome.

Suppioniamo di voler comparare le condizioni atmosferiche (nevicate annuali, piovosita', temperatura media,...) 
di ogni provincia con i dati dei rispettivi stati.  Per fare questa cosa, e' possibile scegliere le colonne da 
visualizzare e quelle da nascondere.

12.  Seleziona il menu' Data > Show Columns (=Dati-Visualizza Colonne). 

13.  Togli la marca a tutte le colonne, eccetto le seguenti:

- COUNTY_NAME
- AVETEMP
- ANNULRAIN
- ANNULSNOW
- STATE_NAME1
- AVETEMP1
- ANNULRAIN1
- ANNULSNOW1

14.  Clicca su OK.

15.  Scorri la finestra dati: appariranno solo le colonne marcate, permettendoci di analizzare i dati che vogliamo 
considerare (in questo caso, le condizioni climatiche).

16.  Chiudi la finestra dati.  Tieni invece massimizzata la finestra della mappa.

17.  Riordina i punti della legenda (trascinandoli col mouse), in modo che siano nel seguente ordine: 
StateNameLabels, Major Cities, Interstates, Final Counties, ZoneAroundMajorCities, and 
ImportedStates.

18.  Salvate il the GeoWorkspace.

Continua con la prossima sezione: 8-Georeferenziazione e Analisi Spaziale
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 Il piazzamento delle etichette

Le etichette (labels) di Geomedia possono essere costituite da testi digitati direttamente o da valori di attributi derivati dai 
dati memorizzati nella warehouse. 

Inserimento di etichette come query

Un'etichetta puo' essere creata sia come query che come feature.  In questa sezione, piazzeremo dell'etichette come query.  

Come vedremo in seguito, piazzare un'etichetta come query permette di associare automaticamente l'etichetta alla feature 
corrispondente.   In questo modo le etichette saranno aggiornate automaticamente al variare dei valori degli attributi che le 
hanno generate (ad esempio cancellando, muovendo e modificando la feature associata).  D'altro canto l'etichette non 
potranno essere modificate fintantoche' non saranno convertite in un feature in lettura/scrittura. 

1.  Selezionare il menu' Insert > Label (=Etichetta).

2.  Nel dialogo Label, selezionate la query Info on Usable Areas dalla lista Label Features in(=Etichetta le 
feature contenute in).

3.  Dalla lista degli attributi, selezionare ANNULSNOW.  

L'attributo apparira' nel campo Layout.

4.  Digitare " (per indicare pollici) dopo l'attributo nel campo Layout.

5.  Assicurarsi che Alignment(=Allineamento) sia settato a Center center.

6.  Assicurarsi che Query (active link, read-only) sia selezionato nel gruppo Output labels as.

7.  Nel campo Query name, digitare il nome Snowfall Labels.

8.  Lascia il nome proposto Final Counties, e clicca sul bottone Style.

9.  Marca l'opzione Bold per fare le etichette in grassetto.  

10.  Marca l'opzione Size remains constant as display scale changes.

11.  Clicca su OK per chiudere tutti i dialoghi.

L'etichette appariranno nella finestra della mappa.
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Inserire etichette come feature

Adesso inseriremo delle etichette in forma di feature  Riversare le etichette in una feature non permette di avere un 
collegamento dinamico ai valori originali, ma d'altro canto permette di modificare le etichette cosi' ottenute, 
indipendentemente dalle corrispondenti feature. 

1.  Seleziona il menu' Insert > Label.

2.  Nel dialogo Label, assicurarsi di aver selezionato la query Info on Usable Areas nella lista Label Features in.

3.  Nel campo Attributes, selezionare COUNTY_NAME.  

L'attributo selezionato appare nel campo Layout.

4.  Clicca su Layout, digitare un carattere spazio dopo l'attributo COUNTY_NAME.  Quindi, digitare COUNTY.

5.  Premere CTRL + ENTER per andare alla linea successiva.

6.  Nel campo Layout, digitare Usable Area:.

7.  Premere di nuovo CTRL + ENTER per andare a capo.

8.  Nel campo Attributes, selezionare area Area.

L'attributo apparira' nel campo Layout.

9.  Sempre nel campo Layout, sulla stessa linea, inserire un carattere spazio e quindi di seguito digitare Sq Mi.

10.  Settare il campo Alignment a Center left.

11.  Selezionare l'opzione Feature Class (static, editable) nel gruppo Output labels as.

12.  In the Connection field, select learning.  

Questa operazione aggiungera' una nuova feature alla warehose learning.

13.  Nel campo Feature class, digitare UsableAreaLabels (senza spazi!). 

14.  Mantieni il nome della finestra mappa a Final Counties per le etichette da visualizzare e quindi clicca sul 
bottone Style.

15.  Marca l'opzione Bold per visualizzare le etichette in grassetto.  

16.  Marca anche l'opzione Size remains constant as display scale changes.

17.  Clicca su OK per chiudere tutti i dialoghi.

Le etichette appariranno nella mappa.

Spostare gli oggetti della mappa
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Osservate che molte delle etichette sulla mappa si sovrappongono.  Dato che abbiamo generato queste etichette come una 
nuova feature, sara' possibile spostarle e modificarle.  Adesso sposteremo alcune etichette, utilizzando due metodi diversi, 
in modo da poterle leggere piu' chiaramente.

Dopo aver completato questo esercizio, le vostre etichette appariranno come nella seguente immagine:

 

1.  Assicurarsi di aver attivato il comando Select.

2.  Selezionare una delle etichette piazzate in precedenza cliccandoci sopra.

3.  Selezionare il menu' Edit > Geometry > Move.  

Il cursore si modifica in una croce.

Ci sono due modi per spostare un oggetto: trascinandolo in una nuova posizione oppure selezionando il punto di 
partenza e di arrivo in cui l'oggetto deve essere spostato.  Useremo adesso il primo metodo.

4.  Premi e mantieni premuto il tasto sinistro del mouse, quindi trascina il testo nella nuova posizione.  

5.  Usa il disegno sottostante come guida per sciegliere dove piazzare l'etichetta.  Dopo aver scelto la nuova 
posizione per l'etichetta, da qualche parte vicino alla relativa provincia (ad esempio proprio sopra o proprio 
sotto), lasciate il pulsante del mouse.

Nota: Non preoccupatevi se il testo visualizzato durante la modifica appare di una dimensione diversa.  I vari 
comandi di modifica che visualizzano gli oggetti in modo dinamico, come ad esempio il comando Move, usano 
lo stile di default per visualizzare il testo.

6.  Seleziona un'altra etichetta da spostare.  

Adesso vedremo il secondo metodo di spostare gli oggetti.

7.  Selezionate Edit > Geometry > Move.

8.  Appena il cursore e' cambiato in una croce, cliccare il punto dell'oggetto che volete utilizzare come punto di 
partenza.  

9.  Cliccare poi sul punti in cui volete spostare l'oggeto.

10.  Utilizzando un metodo a vostra scelta, spostate le altre etichette e posizionatele in modo che non si 
sovrappongono l'una a l'altra.
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11.  Salvate il GeoWorkspace.

Piazzare la North Arrow (=Rosa dei venti) e la barra della scala

GeoMedia Professional permette di posizionare la rosa dei venti e la barra della scala nella vostra mappa.  La rosa dei 
venti e' un'immagine che indica la direzione sulla mappa del Polo Nord Geografico. In una proiezione conica, coma la 
Albers Equal Area utilizzata nei dati di esempio, la direzione del nord varia a seconda della posizione della rosa sulla 
mappa. L'origine della proiezione e' semplicemente il centro degli Stati Uniti. Se posizionate la rosa dei venti solla costa 
occidentale, questa puntera' verso nord-est. Se invece la posizionate sulla costa est, questa puntera' verso nord-ovest.   

La barra della scala mostra la relazione fra l'unita' di misura sul terreno e l'unita' di misura su carta. La barra e' definita 
usando un insieme di intervalli prefissati, di numero e lunghezza definiti dall'utente. Se questi intervalli non sono 
prefissati, la barra della scala sara visualizzata automaticamente con una grandezza che e' il 20 per cento della larghezza 
della mappa, in seguito la dimensione cambiera' dinamicamente al variare dello zoom. 

1.  Selezionate View > North Arrow per piazzare la rosa dei venti.  

La rosa dei venti verra' inserita nella mappa.

Nota: Se non e' possibile vedere la rosa dei venti, forse e' necessario spostare la legenda, dato che la rosa 
potrebbe essere al di sotto.

2.  Cliccate col bottone destro sulla rosa dei venti, quindi selezionate Properties per visualizzare il dialogo North 
Arrow Properties.

3.  Per scegliere una rosa dei venti alternativa, cliccate su Browse (=Mostra).  

Ci saranno alcune rose dei venti da cui poter scegliere quella preferita.

4.  Selezionate ad esempio arrow10.wmf e cliccate su Open.

5.  Rimpicciolite la rosa dei venti, settando il campo Size a 54.

6.  Cliccate su OK per chiudere il dialogo.

7.  Trascinate la rosa dei venti in una nuova posizione della mappa, ad esempio nell'angolo in alto a destra.

8.  Selezionate il menu' View > Scale Bar per piazzare la barra della scala.  

Verra' inserita la barra della scala.

Nota: anche in questo caso, se non vedete la barra della scala, provate a spostate la legenda che potrebbe 
coprirla.

9.  Cliccate col bottone destro sulla barra della scala, quindi selezionate Properties per visualizzare il dialogo 
Scale Bar Properties.

10.  Cambiate il valore Units in mi, vale a dire in miglia.

11.  Cambiate il colore Text/Lines in blu scuro, cliccate su OK del dialogo Color.

12.  Cambiate il colore Minor fill in ciano, cliccate su OK del dialogo Color.

13.  Cambiate il colore Major fill in blu, cliccate su OK.
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14.  Marcate l'opzione Set interval values.

15.  Specificate il valore 5 per il campo Number of intervals.

16.  Settare il valore di Length of interval (=Lunghezza degli intervalli) a 30.

17.  Cliccare su Apply (=Applica) per vedere un'anteprima dei cambiamenti.

18.  Cliccate ancora su OK.  

19.  Trascinate la barra della scala in una nuova posizone nella mappa, come ad esempio l'angolo in basso a destra. 

20.  Salvate il GeoWorkspace.

Cancellare i punti della legenda

Per prepararsi alla stampa finale, e' opportuno cancellare dalla legenda i punti che non ci interessano piu'. 

1.  Se in questo momento la legenda non e' visibile, selezionare il menu' View > Legend.

2.  Selezionare quindi Legend > Properties.

3.  Selezionate i seguenti punti della legenda (non e' detto che siano in questo ordine), cliccando sul selettore di riga 
e tenendo premuto il tasto CTRL:

-Info on Usable Areas
-Usable Areas
-RestrictedZones
-Geocoded Points of Restricted_Sites
-Small Counties Around Major Cities
-Cities
-Counties
-States by Snow/avetemp
-ImportedStates by ANNULSNOW
-States

4.  Cliccate su Delete(=Cancella) per cancellare i punti selezionati.

NOTA: Se cancellate un punto per sbaglio, cliccate sul bottone Cancel per uscire dal dialogo, riselezionare il 
menu' Legend > Properties, e ripetere le operazioni precedenti.

5.  Verificate ora che nella lista Legend Properties appaiano solo i seguenti punti:

- UsableAreaLabels
- Snowfall Labels
- StateNameLabels
- Major Cities
- Interstates
- Final Counties
- ZoneAroundMajorCities
- ImportedStates
- USSampleImage.tif (turned off) - optional

6.  Cliccare su OK per chiudere il dialogo Legend Properties. 

7.  Salvate il Geoworkspace.

Continuate con la prossima sezione 10-Cattura dei dati
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