INTRODUZIONE A |

QUANTUM GIS




Cosa e Quantum GIS

o Conosciuto anche come QGIS
o Software GIS Desktop (Visualizzazione / elaborazione Editing)
o Gratuito ed Open Source

o Le ultime versioni sono molto evolute, si avvicina al top del settore
(ArcGis).

o Esiste anche in versione italiana
o Sito:

o (Nota: per lanciarlo: cliccare su QGis Desktop, non su browser o
altro).
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http://www.qgis.org/it/site/

Panoramica dell’'inferfaccia

Menu e tools

7 QGls2.18.2
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I progetto

o || progetto memorizza:

(o}

(o}

Le impostazioni di lavoro

Il sistema di riferimento
corrente

La legenda (I'elenco dei dati
visualizzati, con i loro stili
assegnati)

La vista corrente della mappa

Puo essere creato nuovo,
salvato e caricato

Il file del progetto NON
comprende i dati geografici

=] @

dals 2,182
ogetto | Modifica  Visualizza Layer Impostazioni  F
Apri... Ctrl+0
Muove da modello
Apri recenti
= salva Cirl+5
) salva Come... Ctrl+5hift+5
I Salva come immagine. ..
Esportazione DXF...
DWG/OXF Impart. ..
" Proprietd progetto. .. Crl +Shift+P
Muova composizione di stampa Cirl+P
+ Gestore di stampe...
Compositore di stampe
Esd da QGIS Cirl+Q
= Layers Panel
-
4 = = £ E =
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Aggiungere

o Cisono vari modi per
aggiungere dati:
1. Cliccare sul menu Layer >
Aggiungi Layer > Aggiungi
vettore o raster

2.

3.

Cercare i dati nel pannello

«browsen)

Trascinare un file nella
finestra della mappa

Progetto

o™ oW o o

4

4

S S s

4

o

o Si possono aggiungere: datfi

vefttoriali, raster o servizi di

rete.

Modifica

@ orade
W rostars

Bl =€

/7 spatalite
& ArcGisFeatures
@' ArcGisMapServe

¢

u

Datl Esistentl
—

Visualizza Impostazioni Plugins Vettore Raster Datsbase Web Progessing Guida

.

osm

® T &

Localita 1
Reg_2016

Crea vettore
Aggiungi layer
Indudi layer e gruppi...

Aggiungi da un file di definizione del layer...

% Copia lo stile
Incolla lo stile
Apri tabella attributi
Attiva modifiche
Salva modifiche vettore
Madifiche in uso

Salva con nome. ..

F&

Salva come file di definizione del layer...

|1 Elimina layer fgruppo
L Duplica layer

Fissa la scala di visibilita del/dei layer

Imposta SR delfi layer
Imposta SR progetto dal layer
Proprieta...
Filtra...
== Etichettatura
oc: Aggiungi alla panoramica
UB Aggiungi tutto alla panoramica
U? Rimuovi tutto dalla panoramica
@ Mostra tutti i layer
Nascondi tutti i layer

®- Mostra layer selezionati

Nascondi layer selezionati

ctrl+D

Ctrl+5hift+C

Ctrl+F

Ctrl+shift+J
Ctrl+shift+H

' h-"_"‘ T T ]

A.-: Aggiungi vettore... Ctr.\‘+Shif‘t+
}:; Aggiungi raster... Ctrl+Shift+R
”:; Aggiungi vettore PostGIS... Ctrl+5hift+D
# Aggiungi vettore Spatialite... Ctrl+Shift-+H
E?; Aggiungi vettore MSSQL... Ctrl+5hift+M
4, Add DB2 Spatial Layer... Ctrl+5hift+2
D_) Aggiungi vettore spaziale Cracle... Ctrl+5hift+0
'\@".‘ Aggiungi layer WMSWMTS. .. Ctrl+Shift-+w

@ Add ArcGIS MapServer Layer...

Q; Aggiungi layer Orade GeoRaster...

@ Aggiungi layer WCS...
/-] Aggiungi vettore WFS...

9;, Aggiungi layer testo delimitato. ..
] Add/Edit Virtual Layer...

Add ArcGIS FeatureServer Layer...
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Nota: | sistemi di riferimento

o Qgis puo utilizzare dati
provenienti da diversi sistemi
di riferimento.

o Bisogna conftrollare pero che
la riproiezione sia attiva:

1.

2.

Cliccare sul menu Progetto
> Proprietd progetto ...

Nel dialogo selezionare il tab
«SR»

Conftrollare che la voce
«Enable on the fly ...» sia
ceccata.

Nuovo
Apri...
Nuovo da modeljo

Apri recenti
-I Salva
ﬂ Salva Come...
=] Salva come immagine.\ .
Esportazione DXF..
DWG/DXF Import...

l Proprieta progetto...

Ctrl+
Crl+0

Ctrl+5
Ctrl+shift+5

Ctri+shift+

v Stili predefinit

IE Server OWS

Muova composizione di stampa Ctrl+P
«| Gestore di stampe...
Compositore di stampe L3
7) Esd da QGIS cirl+Q
Layers Panel
2
o+

0('} Macro

. Sorgenti dei dati

. Variabil
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Filtro

Sistemi di riferimento usati di recente

% Enable 'on the fly’ CRS transformation (OTF)

I Informazioni vettore |S\shema di Riferimento

1D dell'autorita
WGS 34 [ UTM zone 34M EPSG:32634
ETRS8%9 / UTM zone 33M EPSG:25833
WGS 84 EPSG:4326
WGS 84/ UTM zone 33N EPSG:32633
ETRSB% EPSG:4258
ETRS89 / ETRS-LAEA EPSG:3035
WGS 84/ UTM zone 32M EPSG:32632
WGS 84 [ Pseudo Mercator EPSG:3857
(1
Sistemi di riferimento mondiak
|S\shema di Riferimento 1D dell'autorita
WGS 34/ UTM zone 2N EPSG:32602
WGS 84/ UTM zone 25 EPSG:32702
WGS 84/ UTM zone 30M EPSG:32630
WGS 84/ UTM zone 305 EPSG:32730
WGS 84/ UTM zone 31N EPSG:32631
WGS 84/ UTM zone 315 EPSG:32731
WGS 84/ UTM zone 32M EPSG:32632

[

SR selezionato: | WGS 84 f UTM zone 32M

+proj=utm +zone =32 +datum=WGS84 +units=m +no_defs

Coordinata|  401201,4971409 %’ Scala | 1:692.830



Sistemi In uso In [talio

o Monte Mario (Greenwich)

o Monte Mario geografico 2D/3D
[epsg:4265]

o Monte Mario / Italy zone 1 [epsg:3003]
o Monte Mario / Italy zone 2 [epsg:3004]

o Monte Mario (Roma)

o Monte Mario (Rome) geografico 2D/3D
[epsg:4806]

o Monte Mario (Rome) / Italy zone 1 (Fuso
Ovest) (deprecated) [epsg:26591]

o Monte Mario (Rome) / Italy zone 2 (Fuso
Est) (deprecated) [epsg:26592]
o ED50
o EDS50 geografico 2D/3D [epsg:4230]
o EDS50 / UTM zone 32N [epsg:23032]
o EDS50 / UTM zone 33N [epsg:23033]
o EDS0 / UTM zone 34N [epsg:23034]

o ETRS89 (ETRF89)

o ETRS89 geografico 3D [epsg:4937]

o ETRS89 geografico 2D [epsg:4258]

o ETRS89 / UTM zone 32N [epsg:25832]
o ETRS89 / UTM zone 33N [epsg:25833]
o ETRS89 / UTM zone 34N [epsg:25834]
o ETRS89 / LAEA Europe [epsg:3035]

o ETRS89 / LCC Europe [epsg:3034]

o RDN2008 (ETRF2000@2008.0)
o RDN2008 geografico 3D [epsg:6705]
o RDN2008 geografico 2D [epsg:6706]
o RDN2008 / TM32 [epsg:6707]
o RDN2008 / TM33 [epsg:6708]
o RDN2008 / TM34 [epsg:6709]

o RDN2008 / Italy Zone (Fuso lItalia)
[epsq:6875
o RDN2008 / Zone 12 [epsg:6876]
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Muoversi sulla Mappa

o Cisono vari comandi per lo spostamento sulla mappa:

o Ritorno al punto della mappa precedente
o Zoom sull’oggetto corrente
o Zoom su tutta la mappa
o Zoom indietfro
o Zoom avanti
o Spostamento sull’oggetto corrente
o Spostamento Liber \
mpostazioni  Pligins ttore aster Database J[Web Processing Guida
FOR@L P RPPRILWI
T
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Legenda e stili dei Vettoriali

Plugins Vettore Raster Database Web Processing

o Lalegenda elencaidafi “RRLGEoesrinprastee en mwaEE: S

s | RR O 2 B @&« ettore - Localita_11_WGS84 | Stle

della mappa (I'ordine indica ., ..~ = —
il livello di visualizzazione) i e =
. Simboko |Ym |:Egm
o Cliccando col bottone H :
destro su un elemento della™ == .

legenda e selezionando :
«Proprietam, si apre il relativo ' #, |
dialogo N
o Nel tab stile si puo impostare
lo stile di disegno,
eventualmente anche
associato ad un attributo.

uuuuuuuuuuuu

inomina
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Filtro su un layer vettoriale

o Cliccando col bottone | P =@EAz BB A MO
destro sulla legenda, rae e —
selezionando «Filtroy, oppore ST IIITE
il relativo dialogo = o y
> In questo dialogo & possibile & 4 Il 0 ==
inserire un filtro sugli atfributi, | 5.0 = ..
per visualizzare una parte | ‘ =
delle feuture. — S
o Nell’esempio, fra tutte le ‘ ‘
regioni Istat, si visualizza solo o st o e
quella di nome «Toscanaom. s T \
——— ’ | @5
o | . 3
‘‘‘‘‘‘ —
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Formati di dato Raster

o | formati raster rappresentano immagini (Foto aree, scansioni di
carte o strisciate, etc.), oppure dati matriciali (modelli del
terreno).

o QGis, gestisce vari formati di dato raster

o | piv utilizzati sono:
o Tiff + TFW (pud essere mancante del sistema di riferimento)
o GeollFF
o ECW (il migliore)
o | modelli del terreno possono presentarsi in vari formati (asc, bil,
etc.)
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Formati di dato Vettoriale

o Qgis gestisce una grande quantita di formati vettoriali

o Per |'editing si puo tfranquillamente utilizzare il formato shapefile (4
o 5 file per ogni feature).

o Interessante € anche il formato Spatialite (un solo file per tante
feature).

o Se si ha la necessita di editare lo stesso dato
contemporaneamente fra piu operatori € necessario passare ad
un database Postgis.
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Creare un nuovo Shapetfile

o Cliccare su Layer > Crea vettore
> Nuovo shapefile..., nel relativo
dialogo:

1. Selezionare il tipo geometrico
(punto, linea o areq)

2. Lasciamo perdere |la codifica
file

3. Selezioniamo il sistema di
riferimento

4. Aggiungiamo i campi che ci
servono, specificando nome e
tipo (testo, numero, etc.)

5. Clicchiamo ok e salviamo il file.

a | Layer | Impostazioni Plugins

— Crea vettore

Aggiungi layer

Includi layer & gruppi...

Aggiungi da un file di definizione del layer...

E Copia lo stile
Apri tabella attribufi
J  ttivamodifiche
& Modifiche in uso
salva con nome.
82iva come file did
€L, Elimina layer/grupg| Codifica file
P ErWE[_ Duplica layer
vz Fissa la scalzri vis|

Imppsta SR delfila|
Tfmposta SR proget|

Proprieta...
Filra...

I Etichettatura
ita_1T9 Aggiungi alla pano
79 Aggiungi tutto alla
“2 Rimuovi tutto dalla
® Mostra tuttii layer
Nascondi tutti i lay
= Mostra layer selezi

Nascondi layer selg
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Vettore Raster Database ‘Web Processing Guida
v

’ / Muovo vettore Spatialite ...

7 Mew Shapefile Layer

& New GeoPackage Layer.. r
i >
" Nuovo vettore temporaneo...
Ef ‘
? X
Poligor
SR seleziona to (EPSG:4326, WGS 84) -
iNumeri interi i
Pres
Tipo Lunghezza Precisione
Integer 10
String 80
Integer 10 4
<
4[r

Coordinata 717942,4888863



| servizi geografici di rete

o A COSa servonoe
o Servono per mettere ariferimento dati geografici, senza dover
scaricare file o selezionare prima |I'area di interesse
o Sono disponibilie
o La warehouse dell'lGM fornisce una serie di servizi di base

o Quali sono i fipi di servizio?
o WMS: dati raster (immagini, scansioni)
WES: dati vefttoriali
WCS: dati «matrixy (es. DTM, modelli del terreno)
CSW: servizio catalogo di dati geografici
WPS: tool remoti di elaborazione

o

o

o

o
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Esempio WMS: foto Agea

¥ Qais218.2 - o X

Progetto Modifica Visualizza Layer Impostazioni Plugins \Vettore Raster Datsbase Web Progessing Guida
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Esempio WFS: fagli 100k

/ aels2182 u] X
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096
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Y ArcGisMapServer ém'_ 106 ;B\!
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o Prima di iniziare I'editing:
o Cliccare col bottone destro sulla
barra degli strumenti: controllare
che gli «strumenti di
digitalizzazione» e «digitalizzazione
avanzatan siano ceccati

o Cliccare sul menu Impostazioni >
Opzioni di snap.. Selezionare:
o All visible layers
o Al vertice e al segmento
o 5 pixel
o In questo modo i vertici verranno
agganciati a quelli esistenti.

T'DQ mﬁ_vt_

Strumenti Ctrl+Alt+

Editing 1: Preparazione=:.

Layer Order Panel

Layer Styling
® Layers Panel

Log Messages Panel

Owerview Panel

Pannello di digitalizzazione avanzata

Pannello segnalibri geospaziali

Percorso pili breve

Statistics Panel

Tile Scale Panel

Undo/Redo Panel

User Input Panel

Barre degli strumenti

R Barra degli strumenti di digitalizzazione

E3 Barra degli strumenti di digitalizzazione avanzata
Barra degli strumenti raster

R Barra degli strumenti relativi agl attributi
R Barra dei plugin
Barra del database
Barra del vettore
¥ Barra della quida
% Barra delle etichette
Barra web
R Gestisdi la barra dei layer
® Gestisd la barra di navigazione
¥ Project Toolbar
R SwapVectorDirection

 Opzioni di aggancio

Selezione layer | Al visible layers =

Aggancia a Al vertice e al segmento i
Tolleranza | 5,00000 < | pixel -
Abilita la modifica topologica Abilita 'aggancio alle intersezioni Cancel

Apply

Infroduzione a QGis - C. Rocchini



Editing 2. inizio e fine editing

o Periniziare ad editare una feature IR A O e
vettoriale della legenda:
o Selezionare la feature - " mﬁ*l G
o Cliccare sul pulsantfe «Attiva modifican ™ @ /i e n
Preferiti
o Sara possibile modificare lafeature Yo cf
~|E Zif
o Durante I'editing € possibile salvare le © o 5=,
oo ye n = Oradle
modifiche premendo I'icona del 2 | ¥
d iS C h eTTO * "Ja -|: éj i?:(?i:ll;i:ab.lreServer
1 @ .-'-\r:GisMapServer <
o Per terminare I'editing, ricliccare 9 | T e sene e :
sull'icona «afttiva/disattivayn, a questo i . =

punto e possibile salvare o annullare le
modifiche apportate non ancora salvate.

Com2016_WGS84
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Editing 3: Panoramica degli

stfrumenti

o Annulla/ripristina storia
modifiche

o Aftiva/disattiva ediring

o Salva Modifiche

o Cred nuovo oggetto

o (Disegno archi di cerchio)
o Sposta oggetto

o Modifica singoli vertici

o Inverti senso di digitalizzazione
(plugin)

(e]

(¢]

(e]

y

[ o

B -

Oy o

- o
P

! o

O

o

O

o

‘b

Introduzione a QGis

Aftiva digit. Avanzata (es. angoli retti)
Ricalca una parte di feature

Annulla / ripristina

Ruota oggetto

Semplifica forma

Aggiungi buco

Aggiungi parte separata

Crea un buco e con lo scampolo fa
una nuova feature

Elimina buco

Elimina parte separata
Modifica parte del bordo
Linea parallela (solo linee)
Taglia elemento

Dividi parte separata
Cuci elementi adiacenti

- C. Rocchini
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Inciso1: Attributi di default

E' possibile definire un valore di | # s e s s | | | |
defGUH di un O-I--I-ribu-l-o ( dO Modello delfeditor degii atirbuti: | Genera automaticamente +  Funzione di awvio python
assegnare durante I'ediging).

1. Cliccare col bottone destro
su una feature nella legenda

EE0E 14

|1d | Nome | Widget per lamudlﬁcalAIias | Tipo | Mome tipo | Lunghezza | Pri

123 0 |gd Modifica testo glonglong | Integers4

e 1

£ Modifica proprietd widget - gray (bande3)

2. Selezionare «Proprietan

3. Nel dialogo, cliccare sul tab e /S
«Campin

4. Selezionare |I'attributo

Riferimento della relazione| W Constraints

interesessato e cliccare sul i
bottone «Modifica teston E —

5. Digitare il valore scelto nella e T p——
casella «Default Valueyn —
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Inciso 2: aiuto alla
digitalizzazione

E' possibile avere un aiuto A T —

= { E Calcolatore raster ...

. . . . _{‘;q> J--J._‘r-; g [D ( 1] 1] rJ "I>
nella digitalizzazione =
v Interpolazione L |
. [=JIE3 Mappa di concentrazione  * |
] 'I' 1' @ Anal fol 4
. Caricate un raster i et

2. Menu Raster > Conversione | e

. o ;.nahsI; ’ Conversione formati. ..
aaaaaaaa
> Poligonizzatore... T I
. | ~
3 o N el d iO |Ogo SeleZiOnOTe : ] Poligonizzazione (da raster a vettore) . 7 X
I I .I_ d * | File di ingresso {raster) raster - Scegli,..
G ) rG S e r I O V O rO Shapefile di usdita per i poligoni | C:/Temp/gq3 Scegli... [*-\ o

b) Il file shape di uscita | | D e

| Carica sulla mappa quando finito

C ) P re m e -I-e O K gdal_polygonize.bat C:/Temp/raster. tif -f "ESRI Shapefile™ ‘1\

C:/Temp/qg3 gg3 DN L

4. Si ottiene un file shape con
aree uniformi per colore i =) (o=
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